
<!DOCTYPE html>

<html>
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<title>Music industry forces widely used journalist tool offline</title>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Music industry forces widely used journalist tool offline">
<meta name="twitter:description" content="The popular free software project “youtube-dl” was removed from Github on Friday following a legal notice from the Recording Industry Association of America claiming it violates copyright law. The tool is widely used by journalists for various reporting purposes.">
<meta name="twitter:image" content="https://freedom.press/media/images/ytdl-code.original.png">
<meta property="og:url" content="https://freedom.press/news/riaa-github-youtube-dl-journalist-tool/" />
<meta property="og:title" content="Music industry forces widely used journalist tool offline" />
<meta property="og:description" content="The popular free software project “youtube-dl” was removed from Github on Friday following a legal notice from the Recording Industry Association of America claiming it violates copyright law. The tool is widely used by journalists for various reporting purposes." />
<meta property="og:site_name" content="Freedom of the Press" />
<meta property="og:image" content="https://freedom.press/media/images/ytdl-code.original.png" />
<meta itemprop='url' content='https://freedom.press/news/riaa-github-youtube-dl-journalist-tool/' />
<meta itemprop="name" content="Music industry forces widely used journalist tool offline — Freedom of the Press">
<meta itemprop='description' content='The popular free software project “youtube-dl” was removed from Github on Friday following a legal notice from the Recording Industry Association of America claiming it violates copyright law. The tool is widely used by journalists for various reporting purposes.' />
<meta itemprop='image' content='https://freedom.press/media/images/ytdl-code.original.png' />
<meta name="description" content="The popular free software project “youtube-dl” was removed from Github on Friday following a legal notice from the Recording Industry Association of America claiming it violates copyright law. The tool is widely used by journalists for various reporting purposes.">
<meta name="twitter:widgets:csp" content="on">
<meta name="twitter:site" content="@FreedomofPress">
<meta property="fb:pages" content="206351779501843">
<meta property="og:type" content="article" />
<meta name="twitter:creator" content="@xor" />
<link rel="shortcut icon" href="/static/icons/favicon.ico" />
<link rel="mask-icon" href="/static/icons/mask-icon.svg" color="#C70000">
<link rel="apple-touch-icon" sizes="180x180" href="/static/icons/apple-touch-icon.png">
<meta name="apple-mobile-web-app-title" content="FPF">
<link rel="icon" type="image/png" href="/static/icons/favicon-32x32.png">
<link rel="icon" type="image/png" href="/static/icons/favicon-194x194.png">
<link rel="icon" type="image/png" href="/static/icons/android-chrome-192x192.png">
<link rel="icon" type="image/png" href="/static/icons/favicon-16x16.png">
<link rel="manifest" href="/static/icons/manifest.json">
<link rel="mask-icon" href="/static/icons/safari-pinned-tab.svg">
<link rel="shortcut icon" href="/static/icons/favicon.ico">
<meta name="msapplication-TileColor" content="#b91d47">
<meta name="msapplication-TileImage" content="/static/icons/mstile-144x144.png">
<meta name="msapplication-config" content="/static/icons/browserconfig.xml">
<meta name="theme-color" content="#ffffff">
<link rel="stylesheet" href="/static/CACHE/css/a1098317640a.css" type="text/css" />
</head>
<body class="
		
		">
<div class="all-content">
<header class="site-header">
<div class="container">
<div class="site-header-inner">
<div class="site-header__flex-grid-wrapper">
<div class="site-header__flex-grid-1">
<a href="/" class="logo-responsive-wrapper p-y-1">
<svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 563.7 85" xml:space="preserve">
<rect class="logo-rect" width="84" height="23" />
<rect class="logo-rect logo-rect--red" x="92" width="23" height="23" />
<rect class="logo-rect" x="46" y="31" width="69" height="23" />
<rect class="logo-rect" y="62" width="115" height="23" />

<path class="logo-heading-text" d="M156.7,5h-16.8v10.5h14.3v4.7h-14.3v14.6h-5.2V0.3h22V5z" />
<path class="logo-heading-text" d="M175.4,0.3c6.5,0,10.7,4.2,10.7,10.1c0,4.9-3,8.1-6.9,9.1l7.9,15.2H181l-7.3-14.5h-6.5v14.5H162V0.3H175.4z M167.2,5v10.8
		h7.7c3.5,0,5.9-2,5.9-5.4S178.5,5,175,5H167.2z" />
<path class="logo-heading-text" d="M214.8,5H198V15h14.3v4.7H198V30h16.8v4.7h-22V0.3h22V5z" />
<path class="logo-heading-text" d="M243,5h-16.8V15h14.3v4.7h-14.3V30H243v4.7h-22V0.3h22V5z" />
<path class="logo-heading-text" d="M261.3,0.3c4.3,0,7.4,1.4,9.8,4.4c2.5,3.1,2.6,7.4,2.6,12.9s-0.1,9.8-2.6,12.9c-2.4,3-5.5,4.4-9.8,4.4h-12.1V0.3H261.3z
		 M254.4,5V30h6.3c2.5,0,4.5-0.6,5.9-2.3c1.7-1.9,1.8-5.1,1.8-10.2c0-5.1-0.1-8.3-1.8-10.2c-1.4-1.7-3.4-2.3-5.9-2.3H254.4z" />
<path class="logo-heading-text" d="M300.5,3.5c3.4,3.4,3.5,6.8,3.5,14s-0.1,10.6-3.5,14c-2.2,2.2-5.1,3.5-8.9,3.5c-3.8,0-6.7-1.3-8.9-3.5
		c-3.4-3.4-3.5-6.8-3.5-14s0.1-10.6,3.5-14c2.2-2.2,5.1-3.5,8.9-3.5C295.4,0,298.3,1.3,300.5,3.5z M286.5,6.8c-1.7,1.8-2,3.9-2,10.7
		c0,6.8,0.3,8.9,2,10.7c1.3,1.4,3,2.1,5.1,2.1s3.8-0.8,5.1-2.1c1.7-1.8,2-3.9,2-10.7c0-6.8-0.3-9-2-10.7c-1.3-1.4-3-2.1-5.1-2.1
		S287.8,5.4,286.5,6.8z" />
<path class="logo-heading-text" d="M341.2,34.7h-5.2v-23L328,28.5h-3.9L316,11.7v23h-5.2V0.3h5.2l10.1,21.4l9.9-21.4h5.2V34.7z" />

<path class="logo-heading-text logo-heading-text--gray" d="M379.9,3.5c3.4,3.4,3.5,6.8,3.5,14s-0.1,10.6-3.5,14c-2.2,2.2-5.1,3.5-8.9,3.5s-6.7-1.3-8.9-3.5
		c-3.4-3.4-3.5-6.8-3.5-14s0.1-10.6,3.5-14c2.2-2.2,5.1-3.5,8.9-3.5S377.7,1.3,379.9,3.5z M365.9,6.8c-1.7,1.8-2,3.9-2,10.7
		c0,6.8,0.3,8.9,2,10.7c1.3,1.4,3,2.1,5.1,2.1s3.8-0.8,5.1-2.1c1.7-1.8,2-3.9,2-10.7c0-6.8-0.3-9-2-10.7c-1.3-1.4-3-2.1-5.1-2.1
		S367.2,5.4,365.9,6.8z" />
<path class="logo-heading-text logo-heading-text--gray" d="M412.2,5h-16.8v10.5h14.3v4.7h-14.3v14.6h-5.2V0.3h22V5z" />
<path class="logo-heading-text logo-heading-text--gray" d="M449.3,5h-9.5v29.8h-5.2V5h-9.5V0.3h24.2V5z" />
<path class="logo-heading-text logo-heading-text--gray" d="M478.8,34.7h-5.2v-15h-14v15h-5.2V0.3h5.2V15h14V0.3h5.2V34.7z" />
<path class="logo-heading-text logo-heading-text--gray" d="M508.8,5h-16.8V15h14.3v4.7h-14.3V30h16.8v4.7h-22V0.3h22V5z" />

<path class="logo-heading-text" d="M147.7,50.1c6.7,0,11,4.5,11,10.5s-4.3,10.4-11,10.4h-7.8v13.6h-5.2V50.1H147.7z M139.9,54.8v11.5h7.5
		c3.7,0,6.1-2.1,6.1-5.7c0-3.7-2.4-5.8-6.1-5.8H139.9z" />
<path class="logo-heading-text" d="M177.5,50.1c6.5,0,10.7,4.2,10.7,10.1c0,4.9-3,8.1-6.9,9.1l7.9,15.2h-6.1L175.9,70h-6.5v14.5h-5.2V50.1H177.5z M169.4,54.8
		v10.8h7.7c3.5,0,5.9-2,5.9-5.4s-2.4-5.4-5.9-5.4H169.4z" />
<path class="logo-heading-text" d="M216.9,54.8h-16.8v10.1h14.3v4.7h-14.3v10.3h16.8v4.7h-22V50.1h22V54.8z" />
<path class="logo-heading-text" d="M243.4,53.7l-3.3,3.3c-2.1-2-4.6-2.7-7.6-2.7c-4.1,0-6.2,2.2-6.2,5.4c0,1.3,0.3,2.4,1.3,3.2c0.9,0.8,1.9,1.3,3.8,1.5
		l4.1,0.6c3.1,0.5,4.9,1.2,6.4,2.6c1.8,1.7,2.8,4.1,2.8,7.1c0,6.3-5.1,10.1-12.4,10.1c-5.2,0-8.9-1.2-12.2-4.5l3.4-3.4
		c2.5,2.5,5.4,3.3,8.9,3.3c4.5,0,7.1-1.9,7.1-5.3c0-1.5-0.4-2.8-1.4-3.6c-0.9-0.8-2-1.2-3.8-1.5l-4.1-0.6c-2.8-0.4-5-1.3-6.5-2.8
		c-1.7-1.5-2.6-3.8-2.6-6.6c0-6,4.4-10.1,11.5-10.1C237.3,49.8,240.5,51,243.4,53.7z" />
<path class="logo-heading-text" d="M270.8,53.7l-3.3,3.3c-2.1-2-4.6-2.7-7.6-2.7c-4.1,0-6.2,2.2-6.2,5.4c0,1.3,0.3,2.4,1.3,3.2c0.9,0.8,1.9,1.3,3.8,1.5
		l4.1,0.6c3.1,0.5,4.9,1.2,6.4,2.6c1.8,1.7,2.8,4.1,2.8,7.1c0,6.3-5.1,10.1-12.4,10.1c-5.2,0-8.9-1.2-12.2-4.5l3.4-3.4
		c2.5,2.5,5.4,3.3,8.9,3.3c4.5,0,7.1-1.9,7.1-5.3c0-1.5-0.4-2.8-1.4-3.6c-0.9-0.8-2-1.2-3.8-1.5l-4.1-0.6c-2.8-0.4-5-1.3-6.5-2.8
		c-1.7-1.5-2.6-3.8-2.6-6.6c0-6,4.4-10.1,11.5-10.1C264.7,49.8,267.8,51,270.8,53.7z" />
<path class="logo-heading-text" d="M310.7,54.8h-16.8v10.5h14.3V70h-14.3v14.6h-5.2V50.1h22V54.8z" />
<path class="logo-heading-text" d="M335.1,53.3c3.4,3.4,3.5,6.8,3.5,14s-0.1,10.6-3.5,14c-2.2,2.2-5.1,3.5-8.9,3.5c-3.8,0-6.7-1.3-8.9-3.5
		c-3.4-3.4-3.5-6.8-3.5-14s0.1-10.6,3.5-14c2.2-2.2,5.1-3.5,8.9-3.5C330,49.8,332.9,51.1,335.1,53.3z M321.1,56.6
		c-1.7,1.8-2,3.9-2,10.7c0,6.8,0.3,8.9,2,10.7c1.3,1.4,3,2.1,5.1,2.1c2.1,0,3.8-0.8,5.1-2.1c1.7-1.8,2-3.9,2-10.7c0-6.8-0.3-9-2-10.7
		c-1.3-1.4-3-2.1-5.1-2.1C324.1,54.5,322.4,55.2,321.1,56.6z" />
<path class="logo-heading-text" d="M369.6,72.9c0,7.1-5.4,11.9-12.4,11.9c-7,0-12.3-4.8-12.3-11.9V50.1h5.2v22.6c0,4.6,2.8,7.5,7.1,7.5s7.2-2.9,7.2-7.5V50.1
		h5.2V72.9z" />
<path class="logo-heading-text" d="M403.1,84.5h-4.8l-15.9-24.2v24.2h-5.2V50.1h4.8l15.9,24.2V50.1h5.2V84.5z" />
<path class="logo-heading-text" d="M423.2,50.1c4.3,0,7.4,1.4,9.8,4.4c2.5,3.1,2.6,7.4,2.6,12.9s-0.1,9.8-2.6,12.9c-2.4,3-5.5,4.4-9.8,4.4h-12.1V50.1H423.2z
		 M416.3,54.8v25.1h6.3c2.5,0,4.5-0.6,5.9-2.3c1.7-1.9,1.8-5.1,1.8-10.2c0-5.1-0.1-8.3-1.8-10.2c-1.4-1.7-3.4-2.3-5.9-2.3H416.3z" />
<path class="logo-heading-text" d="M467.3,84.5h-5.6l-2.4-6.9h-13.6l-2.4,6.9h-5.6l12.6-34.5h4.2L467.3,84.5z M447.2,73.2h10.6l-5.3-15.3L447.2,73.2z" />
<path class="logo-heading-text" d="M489.2,54.8h-9.5v29.8h-5.2V54.8H465v-4.7h24.2V54.8z" />
<path class="logo-heading-text" d="M499.4,84.5h-5.2V50.1h5.2V84.5z" />
<path class="logo-heading-text" d="M527.5,53.3c3.4,3.4,3.5,6.8,3.5,14s-0.1,10.6-3.5,14c-2.2,2.2-5.1,3.5-8.9,3.5c-3.8,0-6.7-1.3-8.9-3.5
		c-3.4-3.4-3.5-6.8-3.5-14s0.1-10.6,3.5-14c2.2-2.2,5.1-3.5,8.9-3.5C522.4,49.8,525.3,51.1,527.5,53.3z M513.4,56.6
		c-1.7,1.8-2,3.9-2,10.7c0,6.8,0.3,8.9,2,10.7c1.3,1.4,3,2.1,5.1,2.1c2.1,0,3.8-0.8,5.1-2.1c1.7-1.8,2-3.9,2-10.7c0-6.8-0.3-9-2-10.7
		c-1.3-1.4-3-2.1-5.1-2.1C516.5,54.5,514.8,55.2,513.4,56.6z" />
<path class="logo-heading-text" d="M563.7,84.5h-4.8L543,60.3v24.2h-5.2V50.1h4.8l15.9,24.2V50.1h5.2V84.5z" />
</svg>
<h1 class="sr-only">Freedom of the Press Foundation</h1>
</a>
</div>
<div class="site-header__flex-grid-2 hidden-lg-up">
<button class="hamburger hamburger--collapse js-sliding-nav-trigger sliding-nav-trigger pull-xs-right" type="button">
<span class="hamburger-box">
<span class="hamburger-inner"></span>
</span>
</button>
</div>
<div class="site-header__flex-grid-2 hidden-md-down">
<div class="site-header-hider is-in js-search-toggle">
<nav class="site-navigation" role="navigation">
<ul class="site-navigation-nav nav nav--horizontal">
<li class="nav-item--red-box">
<a href="/donate/">Donate</a>
</li>
<li class="nav-item--gray-dark">
<a href="https://store.freedom.press">Store</a>
</li>
<li class="nav-item--gray-dark">
<a href="/contact/">Contact</a>
</li>
<li class="nav-item--gray-dark">
<a href="/about/">About</a>
</li>
<li class="nav-item--gray-dark nav-item--icon">
<a href="http://twitter.com/FreedomofPress">
<svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" class="icon icon--nav" viewBox="0 0 56.693 56.693">
<path d="M53.263,14.565c-1.811,0.805-3.76,1.348-5.805,1.592c2.088-1.25,3.689-3.23,4.444-5.592c-1.953,1.159-4.115,2-6.418,2.454
	c-1.843-1.965-4.47-3.192-7.377-3.192c-5.581,0-10.106,4.526-10.106,10.106c0,0.793,0.089,1.564,0.262,2.303
	c-8.4-0.42-15.848-4.443-20.833-10.559c-0.87,1.492-1.368,3.229-1.368,5.08c0,3.508,1.784,6.6,4.496,8.414
	c-1.656-0.055-3.215-0.508-4.578-1.266c0,0.043,0,0.084,0,0.129c0,4.895,3.483,8.98,8.107,9.91c-0.848,0.23-1.741,0.354-2.663,0.354
	c-0.651,0-1.284-0.062-1.901-0.182c1.286,4.016,5.019,6.938,9.44,7.02c-3.459,2.711-7.816,4.326-12.552,4.326
	c-0.816,0-1.62-0.049-2.411-0.141c4.474,2.867,9.786,4.541,15.493,4.541c18.591,0,28.756-15.4,28.756-28.758
	c0-0.438-0.009-0.873-0.028-1.307C50.194,18.372,51.909,16.593,53.263,14.565z" />
</svg>
<span class="sr-only">Twitter</span>
</a>
</li>
<li class="nav-item--gray-dark nav-item--icon">
<a href="https://facebook.com/FreedomofthePressFoundation">
<svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" class="icon icon--nav" viewBox="0 0 1792 1792">
<path d="M1579 128q35 0 60 25t25 60v1366q0 35-25 60t-60 25h-391v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-735q-35 0-60-25t-25-60v-1366q0-35 25-60t60-25h1366z" />
</svg>
<span class="sr-only">Facebook</span>
</a>
</li>
</ul>
<div class="site-navigation-nav nav nav--horizontal">
<div class="nav-item nav-item--gray-dark nav-item--icon">
<a href="/search" class="js-search-trigger">
<svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" class="icon icon--nav" viewBox="0 0 1792 1792">
<path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" />
</svg>
<span class="sr-only">Search</span>
</a>
</div>
<div class="nav-item nav-item--gray-dark nav-item--uppercase "><a href="/news/">News &amp; Advocacy</a></div>
<div class="nav-item nav-item--gray-dark nav-item--uppercase "><a href="/training/">Guides &amp; Training</a></div>
<div class="clearfix hidden-xl-up"></div>
<div class="nav-item nav-item--gray-dark nav-item--uppercase "><a href="/projects/">Projects</a></div>
</div>
</nav>
</div>
<div class="site-header-hider site-header-hider--absolute js-search-toggle">
<form action="/search/" method="GET" class="header-search">
<div class="header-search-dismiss">
<a class="js-search-trigger">
<svg xmlns="http://www.w3.org/2000/svg" width="40" height="40" class="icon icon--gray" viewBox="0 0 23.79 23.79">
<g>
<rect x="11.4" y="-4.43" width="1" height="32.65" transform="translate(-4.93 11.9) rotate(-45)" />
<rect x="-4.43" y="11.4" width="32.65" height="1" transform="translate(-4.93 11.9) rotate(-45)" />
</g>
</svg>
<span class="sr-only">Show Navigation</span>
</a>
</div>
<div class="header-search-input">
<input type="search" name="query" id="headerSearch" placeholder="Search Freedom of the Press" />
</div>
<div class="header-search-submit">
<button class="header-search-submit">
<svg xmlns="http://www.w3.org/2000/svg" width="40" height="40" class="icon icon--white" viewBox="0 0 24 24">
<g>
<path d="M22.0625,23.6963c-0.4521,0-0.8779-0.1758-1.1982-0.4961l-6.416-6.416l0.707-0.707l6.416,6.416
			c0.1318,0.1309,0.3057,0.2031,0.4912,0.2031h0.001c0.1855,0,0.3594-0.0723,0.4902-0.2031c0.2715-0.2715,0.2715-0.7119,0-0.9834
			l-6.416-6.416l0.707-0.707l6.416,6.416c0.6611,0.6611,0.6611,1.7363,0,2.3975c-0.3193,0.3203-0.7441,0.4961-1.1973,0.4961
			C22.0635,23.6963,22.0635,23.6963,22.0625,23.6963z" />
<path d="M9.5347,18.6992c-5.0869,0-9.2256-4.1387-9.2256-9.2256S4.4478,0.248,9.5347,0.248c5.0864,0,9.2251,4.1387,9.2251,9.2256
			S14.6211,18.6992,9.5347,18.6992z M9.5347,1.248c-4.5356,0-8.2256,3.6899-8.2256,8.2256c0,4.5352,3.6899,8.2256,8.2256,8.2256
			s8.2251-3.6904,8.2251-8.2256C17.7598,4.938,14.0703,1.248,9.5347,1.248z" />
</g>
</svg>
<span class="sr-only">Search</span>
</button>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
</header>
<article class="blog-page">
<div class="container">
<div class="container-narrow m-y-3">
<h1>Music industry forces widely used journalist tool offline</h1>
</div>
<div class="container-narrow m-b-3">
<div class="m-b-1">
<div class="row">
<div class="col-sm-10 col-lg-9">
<div class="media author-tease">
<a class="media-left media-middle" href="/people/parker-higgins/">
<img class="media-object img-circle" src="https://freedom.press/media/images/PA231460-b.2e16d0ba.fill-300x300.jpg" alt="Parker Higgins" width="75" height="75" />
</a>
<div class="media-body media-middle p-l-1">
<div class="h5 m-b-0">
<a href="/people/parker-higgins/" class="link--color-inherit">Parker Higgins</a>
<a href="https://twitter.com/xor" title="@xor"><svg viewbox="0 0 2000 1625.36" width="2000" height="1625.36" version="1.1" xmlns="http://www.w3.org/2000/svg" class="svg-icon icon--link icon--black">
<path d="m 1999.9999,192.4 c -73.58,32.64 -152.67,54.69 -235.66,64.61 84.7,-50.78 149.77,-131.19 180.41,-227.01 -79.29,47.03 -167.1,81.17 -260.57,99.57 C 1609.3399,49.82 1502.6999,0 1384.6799,0 c -226.6,0 -410.328,183.71 -410.328,410.31 0,32.16 3.628,63.48 10.625,93.51 -341.016,-17.11 -643.368,-180.47 -845.739,-428.72 -35.324,60.6 -55.5583,131.09 -55.5583,206.29 0,142.36 72.4373,267.95 182.5433,341.53 -67.262,-2.13 -130.535,-20.59 -185.8519,-51.32 -0.039,1.71 -0.039,3.42 -0.039,5.16 0,198.803 141.441,364.635 329.145,402.342 -34.426,9.375 -70.676,14.395 -108.098,14.395 -26.441,0 -52.145,-2.578 -77.203,-7.364 52.215,163.008 203.75,281.649 383.304,284.946 -140.429,110.062 -317.351,175.66 -509.5972,175.66 -33.1211,0 -65.7851,-1.949 -97.8828,-5.738 181.586,116.4176 397.27,184.359 628.988,184.359 754.732,0 1167.462,-625.238 1167.462,-1167.47 0,-17.79 -0.41,-35.48 -1.2,-53.08 80.1799,-57.86 149.7399,-130.12 204.7499,-212.41" />
</svg></a>
</div>
<div class="rich-text"><p>Advocacy Director</p></div>
<div class="text-muted">
<time datetime="2020-10-26T11:00:00-07:00">October 26, 2020</time>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="blog-page__post-content">
<div class="
						
							container blog-container
						
						block-container--blog-image--center-large
					 ">
<figure class="blog-image blog-image--large">
<img alt="youtube-dl code" class="img-fluid" height="598" src="https://freedom.press/media/images/ytdl-code.original.png" width="1030">
</figure>
</div>
<div class="
						
							container blog-container
						
						block-container--multi
					 ">
<div class="rich-text"><p>The popular free software project “youtube-dl” was removed from Github on Friday following a <a href="https://github.com/github/dmca/blob/master/2020/10/2020-10-23-RIAA.md">legal notice from the Recording Industry Association of America</a> claiming it violates U.S. copyright law. According to the RIAA, the tool&#x27;s “clear purpose” includes reproducing and distributing “music videos and sound recordings ... without authorization.”</p><p>In fact, <a href="https://youtube-dl.org/">youtube-dl</a> is a powerful general purpose media tool that allows users to make local copies of media from a very broad range of sites. That versatility has secured it a place in the toolkits of many reporters, newsroom developers, and archivists. For now, the code remains available to download through youtube-dl&#x27;s own site, but the disruption of its development hub and the RIAA saber-rattling jeopardizes both the future of the software and the myriad journalistic workflows that depend on it.</p><p>Numerous reporters told Freedom of the Press Foundation that they rely on youtube-dl when reporting on extremist or controversial content. Øyvind Bye Skille, a journalist who has used youtube-dl at the Norwegian Broadcasting Corporation and as a fact checker with <a href="https://www.faktisk.no/">Faktisk.no</a>, said, “I have also used it to secure a good quality copy of video content from Youtube, Twitter, etc., in case the content gets taken down when we start reporting on it.” Skille pointed to a specific instance of videos connected to the terrorist murder of a Norwegian woman in Morocco. “Downloading the content does not necessarily mean we will re-publish it, but it is often important to secure it for documentation and further internal investigations.”</p><p>Justin Ling, a freelance investigative reporter who often covers security and extremism for outlets including Foreign Policy and VICE News, described the scenario of reporting on the rise of conspiracy theories as the relevant posts face removal and bans. Youtube “has been a crucial hub for QAnon organizing and propaganda: I&#x27;ve often used youtube-dl to store those videos for my own benefit. Good thing, too, as Youtube often, without warning, mass-removes that sort of content, which can be ruinous for those of us using those Youtube accounts to trace the spread of these conspiracies.”</p><p>In other cases, local copies are necessary to conduct more rigorous analysis than is possible online, and journalists turn to youtube-dl for the highest quality copy of the video available. John Bolger, a software developer and systems administrator who does freelance and data journalism, recounted the experience of reporting <a href="https://hunterenvoy.net/articles/nypd-baruch">an award-winning investigation</a> as the News Editor of the college paper the <i>Hunter Envoy</i> in 2012. In that story, the <i>Envoy</i> used video evidence to contradict official reports denying a police presence at an on-campus Occupy Wall Street protest.</p><p>“In order to reach my conclusions about the NYPD’s involvement... I had to watch this video hundreds of times—in slow motion, zoomed in, and looping over critical moments—in order to analyze the video I had to watch and manipulate it in ways that are just not possible” using the web interface. Youtube-dl is one effective method for downloading the video at the maximum possible resolution.</p><p>Jake, a member of the <a href="https://lucyparsonslabs.com/">Chicago-based transparency group Lucy Parsons Labs</a>, uses youtube-dl to save copies of recorded incidents involving police use of force or abusive behavior. Once copied, the videos can be stored in an archive or modified before publication, such as by blurring the faces of bystanders or victims. “We have sometimes been able to take a closer look at individual frames after downloading with youtube-dl to identify officers when they are not wearing their badges intentionally or obfuscating them with things to avoid accountability.”</p><p>One misinformation researcher told Freedom of the Press Foundation about using youtube-dl to create a baseline for machine learning models developed to do automated real-time fact-checking. “While our production systems are designed to be used on live video streams, it&#x27;s not feasible to test on live video. Youtube-dl allows us to greatly increase the speed of our research development and allow us to be able to actually test our software on a day-to-day basis, not just when politicians happen to have a speech.”</p><p>Similarly, a number of reporters described using youtube-dl for nuts-and-bolts workflows such as transcribing videos they’re covering. Jeremy Gray, a data scientist with The Globe and Mail, described a Slack tool he provides to journalists to allow them to automatically transcribe their own interviews and, until Friday, to transcribe Youtube videos from a URL. “It used youtube-dl, and now that part is broken.” Another journalist, who works at a “small-ish public media newsroom,” described a common situation where a reporter needs “a recording of a public meeting for a story but is on deadline and doesn’t want the hassle of recording the parts they want it in realtime or wants the full file for something like AI transcription.”</p><p>That same journalist described how youtube-dl helps address the challenge of incorporating user-generated content on-air. In the immediate aftermath of an earthquake, their newsroom began expansive continuous coverage and sought to include photos and videos that locals had recorded. “We are scrupulous about making sure we get permission (and the person granting it actually owns the copyright), but especially right after an earthquake asking people to send the video to us specifically can be a much bigger ask than just allowing us to use it (if they even have a recording, which they probably don’t for a livestream), so often after getting permission I’d just download it straight from social media to transcode for TV.”</p><p>That use case is common. Reporters frequently need high-fidelity copies of video or audio tracks for publication or reporting. Ling, the freelance security reporter, said he also uses youtube-dl to “get the best audio quality” when downloading copies of press conferences or news events “to grab snippets of audio for use in podcasts or radio work.”</p><p>Finally, numerous reporters described using youtube-dl to download copies of their own works. Freedom of the Press Foundation has previously worked to <a href="https://freedom.press/news/preserving-threatened-archives-splinter-and-deadspin/">help writers preserve portfolio copies of their articles</a>, and <a href="https://freedom.press/news/archiving-alternative-press-threatened-wealthy-buyers/">to help full news archives stay online</a> when the outlet itself is under threat. Youtube-dl plays an important role in that ecosystem as well.</p><p>Github has not publicly commented on its removal of one of its most popular repositories. Clearly, youtube-dl in particular and the ability to download and manipulate online videos in general are an important part of the work of journalism and contemporary media literacy. Given the important role that youtube-dl plays in public interest reporting and archiving, the RIAA’s efforts to have the tool removed represent an extraordinary overreach with the possibility for dramatic unforeseen consequences. We urge RIAA to reconsider its threat, and Github to reinstate the account in full.</p></div>
</div>
</div>
</article>
<div class="stream-section stream-section--full-bleed stream-section--red-dark">
<div class="container-narrow">
<h2 class="h1 text-xs-center m-b-2 m-t-2">Donate to support press freedom.</h2>
<div class="text-sans-serif text-xs-center text-size--large m-b-2"><div class="rich-text"><p>Your support is more important than ever.</p></div></div>
<div class="text-xs-center m-b-2 p-t-2">
<a href="/donate/" class="btn btn-red-on-white btn-lg text-uppercase">Donate Now</a>
</div>
</div>
</div>
<footer class="site-footer">
<div class="container">
<div class="row">
<div class="col-sm-6 col-md-3">
<div class="site-footer-highlight">Freedom of the Press Foundation</div>
<addr>
<p>601 Van Ness Ave.<br>Suite E731<br>San Francisco, CA 94102</p>
</addr>
<div class="tel">
</div>
<div class="email">
</div>
</div>
<div class="col-sm-6 col-md-3">
<ul class="nav" role="navigation">
<li class="nav-item--gray ">
<a href="/">Home</a>
</li>
<li class="nav-item--gray ">
<a href="/contact/">Contact Us</a>
</li>
<li class="nav-item--gray ">
<a href="/privacy-policy/">Privacy Policy</a>
</li>
<li class="nav-item--gray ">
<a href="/about/">About Freedom of the Press</a>
</li>
</ul>
</div>
<div class="col-sm-6 col-md-3">
<ul class="nav" role="navigation">
<li class="nav-item--gray ">
<a href="/training/">Guides &amp; Training</a>
</li>
<li class="nav-item--gray ">
<a href="/projects/">Projects</a>
</li>
<li class="nav-item--gray ">
<a href="/news/">News &amp; Advocacy</a>
</li>
</ul>
</div>
<div class="col-sm-6 col-md-3">
<p>
This work licensed under a
<a href="https://creativecommons.org/licenses/by/4.0/">
Creative Commons 4.0 Attribution International
</a>
License
</p>
</div>
</div>
</div>
</footer>
<div class="sliding-nav js-sliding-nav">
<form class="sidebar-search" action="/search/" method="GET">
<label class="sidebar-search-icon" for="sidebarSearch">
<svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" class="icon icon--nav icon--gray" viewBox="0 0 1792 1792">
<path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" />
</svg>
<span class="sr-only">Search</span>
</label>
<input class="sidebar-search-input" id="sidebarSearch" type="search" name="query" placeholder="Search" />
</form>
<ul class="nav nav--vertical">
<li class="nav-item nav-item--gray-dark nav-item--uppercase ">
<a href="/news/">News &amp; Advocacy</a>
</li>
<li class="nav-item nav-item--gray-dark nav-item--uppercase ">
<a href="/training/">Guides &amp; Training</a>
</li>
<li class="nav-item nav-item--gray-dark nav-item--uppercase ">
<a href="/projects/">Projects</a>
</li>
</ul>
<ul class="nav nav--vertical">
<li class="nav-item--red-box">
<a href="/donate/">Donate</a>
</li>
<li class="nav-item--gray-dark">
<a href="https://store.freedom.press">Store</a>
</li>
<li class="nav-item--gray-dark">
<a href="/contact/">Contact</a>
</li>
<li class="nav-item--gray-dark">
<a href="/about/">About</a>
</li>
</ul>
<ul class="nav nav--vertical">
<li class="nav-item--gray-dark nav-item--icon">
<a href="http://twitter.com/FreedomofPress">
<svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" class="icon icon--nav" viewBox="0 0 56.693 56.693">
<path d="M53.263,14.565c-1.811,0.805-3.76,1.348-5.805,1.592c2.088-1.25,3.689-3.23,4.444-5.592c-1.953,1.159-4.115,2-6.418,2.454
	c-1.843-1.965-4.47-3.192-7.377-3.192c-5.581,0-10.106,4.526-10.106,10.106c0,0.793,0.089,1.564,0.262,2.303
	c-8.4-0.42-15.848-4.443-20.833-10.559c-0.87,1.492-1.368,3.229-1.368,5.08c0,3.508,1.784,6.6,4.496,8.414
	c-1.656-0.055-3.215-0.508-4.578-1.266c0,0.043,0,0.084,0,0.129c0,4.895,3.483,8.98,8.107,9.91c-0.848,0.23-1.741,0.354-2.663,0.354
	c-0.651,0-1.284-0.062-1.901-0.182c1.286,4.016,5.019,6.938,9.44,7.02c-3.459,2.711-7.816,4.326-12.552,4.326
	c-0.816,0-1.62-0.049-2.411-0.141c4.474,2.867,9.786,4.541,15.493,4.541c18.591,0,28.756-15.4,28.756-28.758
	c0-0.438-0.009-0.873-0.028-1.307C50.194,18.372,51.909,16.593,53.263,14.565z" />
</svg>
Twitter
</a>
</li>
<li class="nav-item--gray-dark nav-item--icon">
<a href="https://facebook.com/FreedomofthePressFoundation">
<svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" class="icon icon--nav" viewBox="0 0 1792 1792">
<path d="M1579 128q35 0 60 25t25 60v1366q0 35-25 60t-60 25h-391v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-735q-35 0-60-25t-25-60v-1366q0-35 25-60t60-25h1366z" />
</svg>
Facebook
</a>
</li>
</ul>
</div>
<div class="sliding-nav-overlay js-sliding-nav-overlay"></div>
</div>
<script type="text/javascript" src="/static/js/bundles/common-c23ac53d9f100ac10455.js"></script>
<script type="text/javascript">
  var _paq = _paq || [];
  
  
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.freedom.press/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', 2]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.freedom.press/piwik.php?idsite=2" style="border:0;" alt="" /></p></noscript>
</body>
</html>
